Stopped syncing with my Fitbit!

I have tried everything and I cannot get them to sync! I have been using it for years and nothing has changed! How can I get them to sync again????

Replies

  • shediv
    shediv Posts: 1 Member
    Same problem here, been using it for over a year with no issues...
  • Tatyanakuster
    Tatyanakuster Posts: 163 Member
    Me too. Any luck yet?
  • gazellefish
    gazellefish Posts: 72 Member
    Mine isn't syncing either - this happened once before and we just kinda had to wait it out, but the status of the API says 'connected' so I'm not sure what's up. :/
  • kr1stadee
    kr1stadee Posts: 1,774 Member
    Mine was as well, but I removed the authority to "talk" to each other, restarted my phone, and then linked accounts again. Works fine now.

    Seems to be a bit of a glitch in the system...
  • Francl27
    Francl27 Posts: 26,373 Member
    edited February 2017
    Yeah it's broken again. Only sees half my MFP calories.

    Had to unlink (MFP then Fitbit) and link again.
  • no44s4me
    no44s4me Posts: 73 Member
    Seems to a widespread issue. Mine's not only not synching with MFP but also not picking up my sleep and exercise activity on the FB app, but it's picking up steps
  • redfroggie
    redfroggie Posts: 591 Member
    I'm having issues with mine not syncing either. So is a disconnect/reconnect the fix around?
  • chaniluv
    chaniluv Posts: 60 Member
    I thought it was just me! I was about to come ask for help, as today is my first day with my Fitbit. I've tried adding the exercises manually to force an update, that didn't work. I also tried disconnecting/reconnecting, still no dice. Hope it's fixed soon!
  • moe72893
    moe72893 Posts: 1 Member
    just bought my first fitbit, have been using the myfitnesspal app to calorie counting & wanted to track steps as well figured my fitbit would help along with that. my Google step couter worked just fine until i wanted it to sync with steps on my fitbit & now shows 0 steps & won't sync. ive tried resetting fitbit, Uninstalling both apps & making sure all permissions are correct. hope this is fixed soon
  • losergood2011
    losergood2011 Posts: 172 Member
    Thank you!! I've been soooo frustrated!!!
  • gazellefish
    gazellefish Posts: 72 Member
    topgals wrote: »
    I've had same problem last couple days & ive just fixed it!
    Through MFP phone app
    Select 'Apps & Devices'
    Disconnect Fitbit & then reconnect
    Go back to previous page of MFP
    Select 'steps' from the list
    Select 'fitbit' to track your steps ... (mine had set itself to 'do not track steps')
    Log out of MFP
    Log back into MFP & you should see your Fitbit steps across top of page, but might be at 0, so you'll need to sync:
    Drag the MFP screen down to sync
    And do same on your Fitbit dashboard

    THIS. DO THIS. This fixed mine after attempting to reconnect/fix it for DAYS.
  • purplekty
    purplekty Posts: 57 Member
    topgals thank you sooooo much!!!

    I was just getting ready to chuck MyFitnessPal!!! The ads are a headache as it is and now my steps where not syncing....I was about done!!

    You Rock!!! Keeping this for future updates..
  • csim
    csim Posts: 1 Member
    I've logged out and in and still cannot choose my FitBit for steps. I click on Browse and the next screen shows I have FitBit installed. Help!
  • wdkincaidmfp
    wdkincaidmfp Posts: 4 Member
    I've logged out and disconnected and turned the phone on/off and gone through that whole cycle about 7 times. Fitbit will not synch. Just won't do it. I am not willing to wait days for this.
  • TerriLH2k2
    TerriLH2k2 Posts: 4 Member
    Fitbit syncs fine with my phone, but neither are syncing with MFP. This is the second fitness tracker I have tried with MFP with the same results--it never syncs. Very disappointing, since I signed up for the Premium service.
  • RetiredAndLovingIt
    RetiredAndLovingIt Posts: 1,360 Member
    Not sure if this is relevant..my friend had a problem with Fitbit One not syncing with her phone or MFP. After shutting her Fitbit down & restarting it, the problem corrected itself.
  • caglew
    caglew Posts: 1 Member
    I've tried everything listed on any help/discussion board. Nothing has worked. MFP hasn't synced with Fitbit since last Thursday 2/23.
  • littlechica299
    littlechica299 Posts: 1 Member
    I've been having this issue as well. I've tried several suggestions that I found in Fitbit forums and then tried @topgals advice and it worked! I added a little twist. Here's what I did:
    Went into apps on MFP (I did it on my phone app but you could do it through the browser too, same thing) and clicked disconnect.
    Then logged into my Fitbit dashboard through the browser, went to apps and actually revoked access to MFP from that side as well.
    I uninstalled both apps off my phone and logged off and exited both websites.
    I restarted my phone
    I waited several hours to make sure they had synced and were for sure disconnected on the backends of the systems, then after about 2 hours finally re-downloaded, logged in and connect the apps again.
    **Restart MFP!**

    After I reconnected the apps it didn't sync right away and I was about to be super grouchy, but then I logged out and restarted MFP per @topgals suggestion and it now works!
    *ugh* Now for them to identify the bug that made it happen so we don't have to go through that again! From everything I've read it's some issue on the MFP side, not the Fitbit side. Good luck everyone :-\