Fitbit Calorie Allowance

Can anyone help me with something please ?
Ive recently upgraded to a Fitbit Sense from a Charge 2.

I'm not sure if that's relevant but my calorie allowance has gone completely wrong.
For example, my daily allowance is 1700 calories, which if I stay within will give me a loss of 1.5lbs per week.

That's all good and has always worked for me in the past. I like to eat though, so I get lots of steps per day so that my calorie allowance rises.

Today I've got 18000 steps on my Fitbit and MFP is only allowing me an extra 45 calories !

Also the steps seem to appear and disappear randomly on the MFP app. Has anyone else experienced anything similar lately ? It's really annoying me tbh.

Thanks in advance.....



  • crb426
    crb426 Posts: 657 Member
    I do notice I need to have both apps open on my phone for them to properly talk to each other. Maybe check that.

    You could always just manually log it under "exercise" to get those calories to show up. Just make sure that you uncheck the box that allows it to deduct calories.
  • Deviette
    Deviette Posts: 978 Member
    How long's this been happening? I recently had to reconnected my fitbit to MFP* and found that it took a day or two for my fitbit calories to be correctly picked up.

    I also have found in the past that sometimes setting my weight loss target speed (calorie deficit per day) on the fitbit app to the same as on MFP. When this did fix something it was a long time ago (and I can't remember what problem it actually solved). I know it shouldn't make a difference, but it's worth a try if nothing else works.

    *because I tried to set a fixed calorie intake, and suddenly my fitbit was saying I was getting ALL of my daily calories as exercise, it was very strange. So I gave up on that and went back to how I had it before, but for that to work I needed to unconnect and reconnect.
  • nanastaci2020
    nanastaci2020 Posts: 1,072 Member
    My guess: there is a temporary glitch in communication between MFP & Fitbit, not a problem with changing your Fitbit device. In the Fitbit app, does it seem to have a 'normal' # of calories burned for you thus far today? If that # seems low then maybe the Fitbit device is wonky. But otherwise, it is a communication between apps thing and hopefully will resolve itself!
  • Cheesy567
    Cheesy567 Posts: 1,186 Member
    edited January 2022
    MFP has been having connectivity issues with Fitbit off and on since mid Dec, they’re aware and trying to fix it. Mine was glitchy again yesterday after having worked well for about a week.

    You can try syncing MFP to save your data, delete the app and re-install, and then reconnect everything. It takes awhile if you’ve been a user for awhile because it has to re-sync all your diary data. But that cleared things up for me yesterday when I couldn’t get the two apps to connect otherwise.