No food consumed yet calories logged!

Hi, yesterday my calories total was over by 620 yet when I added up each meal, drinks etc it should have been 620 less.
I then removed all of my foods/drinks so it should have gone down to zero yet it was saying I had consumed 620 calories still.

I ran a 5k yesterday as well!

I have updated the app and it is still registering 620 calories consumed for food!

I have spent hours trying to sort this, can someone help please?


  • Rockmama1111
    Rockmama1111 Posts: 264 Member
    Do you have MFP synced with a step app where you might have accidentally added a meal?
  • Lietchi
    Lietchi Posts: 5,551 Member
    Have you tried 'selecting all' and then deleting (using the pencil icon at the top of the diary, in the app)?
  • FranCutts
    FranCutts Posts: 2 Member
    Thank you! I used the pencil and it worked!! I've only been using MFP for about 7 years & never noticed the pencil before! I wonder where those calories were hiding?

    Thanks again :)
  • koushk13
    koushk13 Posts: 1 Member
    What is pencil ? I am having the same issue
  • Lietchi
    Lietchi Posts: 5,551 Member
    At the top of the diary: