Fitbit wont sync with myfitness pal

So im having trouble getting my fitbit to sync with my fitness pal app. I have deactivated and resynced them both. It says they are both synced...but when i click sync on the myfitness pal app nothing for my exercise for the day shows up. I walk all day at my work and have burnt over 2k calories. I have the fitbit charge HR btw.

Please help!!!


  • grannynot
    grannynot Posts: 146 Member
    My Vivofit "syncs", but MFP doesn't credit me with steps above-and-beyond the normal activity. My calories from MFP transfer to my Vivofit; so the Vivo might say I ate less than my total calorie burn for the day - but MFP will still insist I ate too many calories. I'll be watching your post to see if someone more techie than me can explain...
  • ksved187
    ksved187 Posts: 64 Member
    im having the same issue as well. its showing its connected but not showing my fitbit steps. i tried disconnecting to try again but it wont let me do that either. (ive tried with a fitbit zip and fitbit charge hr)

    let me know if you find a solution, thanks
  • RuNaRoUnDaFiEld
    RuNaRoUnDaFiEld Posts: 5,864 Member
    I've had the same problem for the last few days. Can't work out why. I'm going to contact live chat later.
  • shopaholic97504
    shopaholic97504 Posts: 8 Member
    I've had the same problem for the last few days. Can't work out why. I'm going to contact live chat later.

    Please let us know what they say. It's nice to know if I earn calories by walking a bunch during my days.
  • Andrea1046
    Andrea1046 Posts: 2 Member
    Yes, please do--I've got the same problem: since 8/6! Getting ready to dump MFP if something doesn't change soon...
  • vschussler2009
    vschussler2009 Posts: 1 Member
    Bumping this because I'm having the same issue :-/ just started a little bit ago restarted, reinstalled, synced, and about ready to throw some stuff lol j/k
  • slaclark22
    slaclark22 Posts: 4 Member
    I can't get my fitbit HR charge to sync with my fitness pal either. I have tried disconnecting and reconnecting with no luck and tried entering exercise data to jump start it as mentioned as a suggestion, but that doesn't work either. This used to be a seamless process. What happened?
  • CharlieBeansmomTracey
    CharlieBeansmomTracey Posts: 7,682 Member
    edited August 2016
    go to apps on your main page(mfp not fitbit) on a pc,then select steps,make sure that fitbit is selected,if not select it and that should fix the issue. mine was unchecked somehow and was having the same issues. but it wont show until tomorrow most likely(took mine 24hrs to reset itself to track steps again). hope that helps