Why is it so difficult to search ingredients in MFP??

thesweetpea59
thesweetpea59 Posts: 40 Member
I am SO frustrated. Making my recipe in MFP and while inputting ingredients, I always search and try to get the exact same one that i am using so I can get the most accurate calorie count. So I am making a recipe right now that includes tortillas. So I search tortilla, tortillas, corn tortilla, Guerrero corn tortilla, white corn tortillas, EVERYTHING and I just keep getting things like Tortilla Soup, Salad on Tortilla, Tortilla chips, Beef Fajita with tortilla. WTF! Just give me TORTILLA already! It's easier just to freaking input the ingredient myself into the stupid data base.

Ok. Rant over.
«1

Replies

  • zyxst
    zyxst Posts: 9,134 Member
    Idk when that changed, but the search engine picks one word and gives you everything that has that word. Though I know I'm already clogging up a clogged database, it's simpler to add my own entry than dig through all the others (or find the one that I corrected).
  • PJPrimrose
    PJPrimrose Posts: 916 Member
    IDK, but it IS really, really irritating searching about while trying to pull dinner together!
  • hortensehildegarde
    hortensehildegarde Posts: 592 Member
    put in the brand first and it should pop right up. I never have any issue finding the right one if I do Kroger tortilla or Mission yellow corn tortilla, something like that. The "Guerrero corn tortilla" brought up white corn tortilla, corn tortilla, tortilla, mini tortilla (all within that brand) so that one worked fine for me?

    ETA: the "exact same one" often has the wrong info for me, due to changes in brand, different places it being differently sized, so after I find "Mission yellow corn tortialla" or whatever I have I always check against the package to make sure its the same one, i.e. if the package says 120 cals for 3 tortillas that the MFP entry also has them listed as 40 cals per tortilla
  • Jessesbride
    Jessesbride Posts: 21 Member
    If it has a barcode, I've just noticed that's much easier to use...
  • thesweetpea59
    thesweetpea59 Posts: 40 Member
    I'm not sure we are all talking about the same thing. Searching for an ingredient or food from within the food diary works very well and enters into a huge, massive database. I almost always find what I'm looking for there. But from within the Creating a Recipe tool, it's a very different story. I put in Guerrero (the brand) and I get nothing. I put in Corn Tortilla and I get 2 very obscure (for me) brands that do not have a similar nutritional value. I just end up using the closest one. No option to use a barcode scanner there (I'm on the computer) and no option to add a new ingredient to the database there. I see for past recipes I have added Guerrero tortillas....not sure how I did it then!
  • MelonJMusic
    MelonJMusic Posts: 121 Member
    UGH! I have this problem too. I have all of these database foods in my recently and frequently used, but when putting together a recipe, NO WHERE TO BE FOUND! It's also making meal entry tedious, especially when it has more than 6 ingredients.

    It's weird because it used to be very good (still not as easy as the main database, but good) and find it via brand almost instantly when I enter exact wording. Now, it's not even there, and it appears to be getting worse. :explode:
  • hortensehildegarde
    hortensehildegarde Posts: 592 Member
    OH! you are correct, 2 different things! I didn't even know you could do such a thing as when I am making a recipe I always just add in the individual components from the main database. Well that seems silly for one to work and not the other, no wonder you are frustrated!
  • bunny1006
    bunny1006 Posts: 325 Member
    bump
  • becsnz1
    becsnz1 Posts: 85 Member
    Yep I get that same issue too with the new recipe builder, it's hopeless and damn frustrating so I always go back to the old recipe builder, find that way less frustrating!
  • MrsZ_71
    MrsZ_71 Posts: 5
    I am glad I am not the only one who is frustrated, I have ended up not putting my evening meal on so therefore am "under" my calories because I cant get it right. I too would like to enter my recipe using my normal tried and tested ingredients. Would it be worth (in the first instance) entering them all on separately then creating a recipe from "My Foods" although I only have a few foods in My Foods and tbh I don't know how they got there. I didn't know that you could use the old recipe builder so perhaps I will give that one a try.
  • JennetteMac
    JennetteMac Posts: 763 Member
    Totally agree. Bring back the old one!:grumble:
  • Healthydiner65
    Healthydiner65 Posts: 1,579 Member
    Tip: some very intelligent MFP members have started adding the calorie count to their entries. Like WW giant fudge bar 100. Makes it much easier!
  • skhuu
    skhuu Posts: 25 Member
    OMG i have this problem. I was writing a recipe that used greek yogurt. I KNOW the 365 brand greek yogurt exists in the database but disappears when I try to add the ingredient to a recipe. It is really annoying. I end up choosing another entry that has similar nutrients.
  • dsb188
    dsb188 Posts: 121 Member
    Sometimes mine freezes when I'm entering in a long list of ingredients but than I think to myself. This app is free and its changing my life so I just restart and keep it moving haha,
  • HipsterWhovian
    HipsterWhovian Posts: 195 Member
    I have this problem whenever I search for eggs in the recipe builder!
  • SezxyStef
    SezxyStef Posts: 15,268 Member
    I just entered a recipe in the builder no issues at all. Took me 2 mins and it had over 15 ingrediants.

    I don't always look for the brand I look for the USDA entry.
  • amifit6
    amifit6 Posts: 4 Member
    I'm having similar issues with building a recipe. It is very frustrating.

    Someone mentioned the old recipe builder? Can I still find that to use?
  • thesweetpea59
    thesweetpea59 Posts: 40 Member
    I see now that the key is to use the OLD Recipe Calculator located at the upper right of the main recipe page. This calculator gives you access to the big main food database. Everything is right with the world. :drinker:
  • KayJaMikel
    KayJaMikel Posts: 341 Member
    At least they are in the database. I have signed up to 2 or 3 places similar to this one over past few days, but I try to enter my items, things that this database readily has, and nothing comes up. You have to enter pretty much everything from scratch, which is really difficult.
  • shaynepoole
    shaynepoole Posts: 493 Member
    it's been like that for a while now - if you use the older version - there is a button to the right on the initial recipe input page, you will get the right items, except you have to input them in one by one

    I really hope they fix the other way soon